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Introduction
Oracle Open Office has something for everybody. Existing users of StarOffice and 

StarSuite (which has been renamed Oracle Open Office) get better Microsoft Office 

compatibility (including import of Microsoft Office 2007 OOXML files), new and improved 

productivity tools, usability enhancements for all applications, and an online update 

feature that makes installing product updates and extensions a snap. Mac users get a 

native port of Oracle Open Office and, with that, a full-featured office suite that can read 

from and write to Microsoft Office files. Microsoft Office users have an office suite that 

offers the features they need—including a Microsoft Outlook alternative—and get a 

familiar user interface at a great price. Developers and independent software vendors 

(ISVs) benefit from an extension framework that enables them to develop their own 

components for Oracle Open Office that can be used to add value to their offerings. 

Educators and students will appreciate the Web 2.0 tools, multilingual writing aids, 

improved online help, and advanced graphics capabilities of this award-winning office 

suite. In addition to its comprehensive functionality and strong compatibility, Oracle Open 

Office offers stability, reliability, security, and accessibility in a low-cost, full-featured 

office suite.

The features of Oracle Open Office include

• Comprehensive office productivity. Oracle Open Office software provides word 

processing, spreadsheet, and presentation software as well as drawing, database, and 

HTML capabilities.

• Microsoft Office compatibility. Read, edit, and save to Microsoft Word, Microsoft 

Excel, and Microsoft PowerPoint file formats in releases from Microsoft Office 97 to 

Microsoft Office 2007 (read-only).



• OpenDocument (ODF) format. Oracle Open Office supports ODF 1.2, the ISO 

standard file format for office suites, which is its default file format.

• Multiplatform capabilities. Oracle Open Office software runs on Microsoft Windows, 

Mac OS X, Linux, and the Oracle Solaris operating system (SPARC and x86).

• Support for third-party applications and file formats. In addition to Micrososft Office 

file formats, Oracle Open Office supports documents in PDF, Flash, WordPerfect, 

Lotus 1-2-3, and HTML.

• Import and editing of PDF files. Oracle Open Office delivers the ability to import PDF 

files, so you can edit them and export them back to PDF. 

• Familiarity for users. Users of Microsoft Office will find Oracle Open Office easy to 

learn, because of its familiar user interface, including industry-standard menus, icons, 

dialog boxes, and layout.

• Accessibility support. Through third-party assistive technology tools, Oracle Open 

Office—and its online help and user documentation—can be used by people requiring 

large fonts, screen readers, and alternative input devices.



Oracle Open Office Applications

The Oracle Open Office productivity suite consists of the following applications:

Oracle Open Office Writer (Word Processing) 

Oracle Open Office Writer is a word processor that provides flexible tables, frames for 
highlighting, columns for professional layouts, indexes, tables of contents, forms functionality, 
graphics handling, and built-in PDF export. It can read, edit, print, and save Microsoft Word 
files. Whether you need to snap out a quick memo or craft an in-depth report with a table of 
contents, diagrams, and indexes, Oracle Open Office Writer makes it simple.

Oracle Open Office Calc (Spreadsheet) 

Calc is a spreadsheet application that provides professional data calculation, hundreds of 
different formulas, a DataPilot (similar to Microsoft Excel’s pivot table), powerful autofilters, a 
linear solver, access to external datasources, powerful 2-D/3-D charts, a formula detective, a 
scenario calculator, and more. It can read, edit, print, and save Microsoft Excel files, and it 
enables you to calculate, analyze, and share your data quickly and easily.

Oracle Open Office Impress (Presentation) 

Impress is a presentation tool that provides an intuitive front end for creating and editing 
presentations, dozens of slide and custom animations, easy-to-use tables, autoshape support, 
comments and notes, master functionality, and a presenter console (similar to Presenter View in 
Microsoft PowerPoint). It can read, edit, print, and save PowerPoint files. 

Oracle Open Office Draw (Vector Graphics)

Draw is a vector graphics application that provides dozens of shapes as well as connectors for 
creating flowcharts, diagrams, floor plans, organizational charts, and much more. It helps you 
bring your communications to life with easy-to-create drawings, sketches, and the like.

Oracle Open Office Base (Database Front End)

Base is a database front end in Oracle Open Office. It provides a forms editor with 25 different 
controls; subform support; macro capabilities; a query editor; a powerful report editor; and 
connectivity via MySQL, JDBC, and Open Database Connectivity (ODBC). It enables you to 
easily create self-contained database documents with all relevant data, table definitions, reports, 
and forms.



Key Focus Areas and Benefits of Oracle Open Office 

When the latest version of Oracle Open Office was being designed, close attention was paid to 
feedback from existing users from around the globe as well as users of other office suites and 
platforms. It provides many new and enhanced features and key changes:

Interoperability and File Sharing

It is very easy for users of Oracle Open Office to share files and data with users of other office 
suites. Oracle Open Office delivers world-class Microsoft Office filters and support for the 
Microsoft Office 2007 OOXML file format. It also offers PDF import, so you can edit PDF 
files, and superb one-click PDF export with a rich set of security and hyperlink options, along 
with PDF/A support.

Communication 

With Oracle Open Office, Oracle provides a calendar extension called Lightning to go with the 
Mozilla Thunderbird client. Together, they serve as a personal information manager (PIM) and 
form a strong Microsoft Outlook alternative. There are also two Web-based tools that make it 
easier to communicate on the internet—a blogger and a MediaWiki publisher.

Multiplatform Capabilities

Oracle Open Office provides support for the Mac OS X operating system, which gives users 
exceptional flexibility in choosing their platform. Besides running on the Mac OS X platform, 
Oracle Open Office runs on Windows, including Windows 7; Linux; and Oracle Solaris. 

Collaboration

A single workspace for documents is key for efficient workflow. Oracle Connector for Microsoft 
SharePoint Server and Oracle Connector for Alfresco CMS provide full access to documents 
stored in Microsoft Office SharePoint Server 2007 and Alfresco CMS servers. It enables Oracle 
Open Office users to search, edit, or write documents stored on the server and adds support for 
the ODF file format.

Usability

Oracle Open Office uses classic usability elements familiar to the majority of Microsoft Office 
users. The users are familiar with the Oracle Open Office graphical user interface from the 
beginning and therefore require minimal or no retraining. For users who are interested in 
training, many courses are available, including a Microsoft Office transition class. 



Calc comes with a Solver component for solving optimization problems and offers a chart 
component with many formatting options. Presenters may benefit from the native table feature 
in Impress, as well as two extensions: the Oracle Presentation Minimizer, which compresses 
presentation document files, and the Oracle Presenter Console, which enables users to view the 
speaker notes and the next slides while presenting.  Finally, Base can be extended with the 
powerful Oracle Open Office Report Builder.  Therefore, your productivity will increase with 
Oracle Open Office. 

Summary of the Key Features

The following tables provide a summary of the key features, benefits, and access points of Oracle 
Open Office.

TABLE 1. INTEROPERABILITY ENHANCEMENTS

FEATURE BENEFIT HOW TO ACCESS

Microsoft Office compatibility • Enhanced import and export for Microsoft 

Office word processing, spreadsheets, and 

presentations

• Ability to import Microsoft Office 2007 

OOXML files

• Ability to read password-protected 

Microsoft Office XML files and templates

• Import of OLE objects, form controls, and 

pivot tables from Microsoft Excel 2007 files

• Happens automatically while opening 

and saving files

Oracle PDF import • Ability to edit PDF documents • Available as an extension at 

http://sun.com/ooo_extensions

Export to Adobe PDF/A • PDF/A support

• Support of hybrid ODF/PDF files

• Increased security of PDF files

• Better user of links within PDF files

• Saving files as read-only documents in 

the popular PDF format is quick and 

convenient, and the saved PDF is true 

to the original.

ODF capabilities • Supports v1.2, so you have the latest ISO 

standard

• Hybrid ODF/PDF, so you can edit in ODF 

and save in PDF at the same time

• Save file



TABLE 2. PRODUCTIVITY ENHANCEMENTS

FEATURE BENEFIT HOW TO ACCESS

Writer functionality • Full-featured text processor applications

• Seven different indexes, including a bibliography

• Mail merge feature for printing or generating e-mails 

• Text tables, frames, sections, images, and dozens of other 

features

• File –> New –> Text Document

Base functionality • Rich-featured database application including forms, queries, 

and reports

• Self-contained database documents with all relevant data, 

table definitions, reports, and forms 

• Ability to connect to MySQL; JDBC; ODBC; and, in 

Windows, to Microsoft Access databases

• Easier, faster creation of stylish database reports, with 

Oracle Open Office Report Builder extension

• File –> New –> Database

• Oracle Open Office Report Builder 

available as an extension from 

http://sun.com/ooo_extensions

Calc functionality • Full-featured spreadsheet application

• More than 80 chart types

• Solver and Scenario Manager

• DataPilot, also known as pivot table

• More than 275 formulas 

• File –> New –> Spreadsheet

Impress functionality • Full-featured presentation application

• 158 animation and 59 slide transition effects

• 3-D styles and effects

• Ability to see the upcoming slide or speaker notes when 

presenting with Oracle Presenter Console

• File –> New –> Presentation

• Oracle Open Office Report Builder 

available as an extension from 

http://sun.com/ooo_extensions

Draw functionality • Rich-featured vector-oriented drawing application

• Ability to create organizational charts, network diagrams, 

floor plans, and lots more

• More than 100 shapes

• File -> New -> Drawing



TABLE 3. OTHER FEATURE ENHANCEMENTS

EXTENSION AND DEVELOPER BENEFIT HOW TO ACCESS

Extension framework • Enables users to develop 

components or extensions on top of 

Oracle Open Office that can add 

value to a developer ISV offering 

• The “Extensions” chapter of the 

Developer’s Guide provides an 

introduction.

LOCALIZATION TECHNOLOGY

Arabic support • Gives more people access to a full-

featured, low-cost office suite

• Install on your computer

Outstanding bidirectional, right-to-left, 

complex text layout capabilities

• Gives more people access to a full-

featured, low-cost office suite

• Install on your computer

MULTIPLATFORM AND CROSS-PLATFORM 

Mac OS X, Oracle Solaris, Linux, 

and Windows platforms, including 

Windows 7

• Enables users of all major platforms 

to share files and information

• Install on your computer

COMMUNICATION AND COLLABORATION 

Mail/calendar client • Based on Mozilla Thunderbird 

• Gives users a Microsoft Outlook 

equivalent with the mail client and 

calendar extension 

• Gives users e-mail, scheduling, and 

to-do lists

• Go to www.mozilla.com to download the 

Thunderbird mail client.

• Go to www.mozilla.com to download the 

Lightning calendar extension for 

Thunderbird.

Oracle Weblog Publisher (blogger) • Enables users to blog easily and 

directly from Oracle Open Office

• Available as an extension from 

http://sun.com/ooo_extensions

Oracle Wiki Publisher • Enables users to publish and post 

to MediaWiki pages from Oracle 

Open Office

• Available as an extension from 

http://sun.com/ooo_extensions

How to Get Oracle Open Office with Extensions and Mail/Calendar Client

Oracle Open Office comprises three parts, all available as a download.

Oracle Open Office Core Product

This includes the standard product with the core features, Microsoft Office interoperability, 
accessibility, and PDF export. Download the Oracle Open Office core product from 
oracle.com/us/products/applications/open-office/index.html.



Oracle Open Office Extensions

These are add-ons—such as Oracle Weblog Publisher, Oracle Connector for Microsoft 
SharePoint Server, and Oracle PDF Import Extension—that provide extra functionality.

Download extensions for Oracle Open Office from http://sun.com/ooo_extensions.

PIM: Mozilla Thunderbird and Lightning

Oracle Open Office developers contributed heavily to Mozilla Lightning to turn it into an 
enterprise-class calendar client.

• www.mozilla.com/en-US/thunderbird/

• www.mozilla.org/projects/calendar/

Oracle Open Office Feedback and Support

Oracle appreciates your feedback about Oracle Open Office and would like to invite you to join 
Oracle-moderated public Oracle Open Office support forums, via the following URLs:

• Oracle Open Office 3. General discussion on http://forum.java.sun.com/forum.jspa?
forumID=926 for feedback on all findings about Oracle Open Office 3

• Oracle Open Office 3. Discussion on http://forum.java.sun.com/forum.jspa?forumID=927 
for feedback on Oracle Open Office 3 installation issues

• Oracle Open Office 3. Discussion on http://forum.java.sun.com/forum.jspa?forumID=928 
for feedback on Oracle Open Office 3 extensions

Oracle is very much looking forward to hearing your feedback. 

For more support, go to www.support-central.org.

Interoperability and Standards

Oracle Open Office extends its already strong open standards support. An increasing number of 
governments around the globe have started to mandate and adopt the ISO standard PDF/A for 
archiving documents in a read-only format, in addition to the ISO standard ODF for editing 
documents. As a consequence, Oracle Open Office supports PDF/A as well as always 
supporting the latest version of the ODF standard because ODF is the default file format of 
Oracle Open Office. 

Oracle Open Office can also import and edit PDF files via the Oracle PDF Import Extension. 
And finally, Oracle Open Office provides import filters for the Microsoft Office 2007 OOXML 
format. Thus, Oracle Open Office is the perfect office suite for standards-based collaboration 
across various platforms. 



OpenDocument Format Support

Oracle Open Office will always support the features of the latest versions of its ISO-standard 
default file format, ODF. ODF is being mandated and adopted in a growing number of countries 
and being implemented by many vendors for many different applications. The latest ODF 
version, 1.2, includes a powerful formula language and a sophisticated metadata model based on 
the World Wide Web Consortium (W3C) RDF and OWL standards. Oracle Open Office also 
enables you to preselect the ODF format version (v.1.1 or v.1.2) you want to work with.

Microsoft Office 2007 Import Filters

In addition to having excellent file sharing abilities with Microsoft Office binary file formats 
(.doc, .xls, .ppt, and so on), Oracle Open Office can open files created with Microsoft Office 
2007 or Microsoft Office 2008 for Mac OS X (.docx, .xlsx, .pptx, and so on). Thus, Oracle Open 
Office users can easily share files with Microsoft Office users. The various filters for the 
Microsoft Office file formats also make mixed environments possible, so some users can stay on 
Microsoft Office while others can use Oracle Open Office.

Enhanced PDF Support

The PDF export functionality in Oracle Open Office offers extended options. For example, the 
PDF export filter can export documents with links made relative. Writer bookmarks, Impress 
slide names, Draw slide names, and Calc sheet names are exported as named destinations in the 
PDF document and can be linked directly from another PDF document. The default zoom level 
and the number of disclosed levels in the bookmark hierarchy can be set. Additional features 
include

• PDF security options. Security settings for the PDF export dialog box control the encryption 
of the generated PDF. Printing permissions and document changes can be restricted.



 

• PDF/A support. In addition to the ODF ISO standard , OpenOffice.org also supports the 
popular PDF/A ISO standard. Whereas ODF is used for editing documents, PDF/A is 
popular for archiving read-only versions of documents.

• PDF import. This feature is available as an extension.

• Hybrid PDF. A PDF and the original document from which the PDF was created are used 
for different purposes. If changes are required in the PDF document, the author of the 
document will normally make edits in the original document and create a new PDF. It is the 
responsibility of the document author to make sure that the original document does not get 
lost. Often enough, though, the original document of a PDF is not at hand when changes need 
to be made in the PDF. For these cases, using a “hybrid PDF” file is a way to solve the 
problem. A hybrid PDF file created with Oracle Open Office is a combination of ODF and 
PDF. A hybrid PDF document contains the original ODF document, which enables the user 
to store just a single PDF file. When edits are necessary in this PDF, these files can be opened 
with Oracle Open Office. This feature requires the Oracle PDF Import Extension.

Oracle Open Office autodetects the attached ODF file and opens it like a usual ODF file to 
allow full editing. When the changes are done, the document is again saved as a hybrid PDF. The 
result is that there is just one file for editing and sharing. Those who do not have Oracle Open 
Office or OpenOffice.org can view the PDF in Adobe Acrobat Reader.

Microsoft Windows 7 Support



Oracle Open Office fully supports the Microsoft Windows 7 platform, with all of its extended 
features and technologies. It runs on 32- and 64-bit versions of Windows 7.

Preselect ODF Version and Size Optimization for ODF 

Oracle Open Office supports ODF 1.2 in addition to ODF 1.0/1.1. It is possible to preselect the 
ODF version. Because ODF 1.2 is not approved as the ISO standard yet, it is important for 
many customers to be able to use the approved ODF 1.1 standard.

The size optimization option reduces the file size even further, although ODF is already a 
compressed file format.

How to Access

• Choose Tools -> Options -> Load/Save -> General.

Feature Highlights 

Oracle Open Office is a mature and feature-rich office suite. This section highlights just a few of 
its features.

Oracle Open Office Writer

Note-Taking Feature

Oracle Open Office Writer offers a powerful note-taking feature that enables you to display the 
notes at the edge of the document. In addition, notes from different users are displayed in 
different colors, together with the editing date and time. Users can also reply to other users’ 
comments and share feedback.



How to Access

Choose Insert -> Note.

PDF Import

Oracle PDF Import Extension enables you to modify existing PDF files for which the original 
source files may not exist. PDF documents are imported in Draw and Impress (not in Writer) to 
preserve the layout, which is done better in Draw or Impress, and then after the import, to allow 
basic editing.  Native PDF forms cannot yet be imported. Oracle PDF Import Extension enables 
you to export into a hybrid PDF file, which is a PDF with the embedded source file in ODF. 
Hybrid PDF files will be opened in Oracle Open Office as ODF files without any layout 
differences, and users without Oracle Open Office can open the PDF part of the hybrid file (see 
also “Hybrid PDF” in the “Interoperability and Standards” section).

How to Access

Install Oracle PDF Import Extension.

Zoom Slider and Support for Large Monitors 

When you are writing larger documents, it is often helpful to see the current page in context with 
the previous and next pages. The zoom slider makes it easy to change the zoom factor, and more 
importantly, Oracle Open Office Writer can display multiple pages for editing side by side. This 
feature is particularly handy on wide-screen monitors or dual-monitor setups.



How to Access

Adjust the status bar at the bottom edge of the window.

Language Selector in Writer Status Bar

The language selector tool in the status bar makes assigning a variety of languages to different 
paragraphs very simple. Thus, editing and spell-checking documents that are written in more 
than one language become very easy. The entire document language can also be changed with 
this control.

How to Access

Right-click Language Selector in the status bar.

Language Guessing for Paragraphs in Writer



This feature enables you to ascertain the language of a text selection. The algorithm works 
without using a dictionary, so the language can be ascertained even if the dictionary isn’t installed 
for that language. The feature uses a statistical approach to ascertain the language. The algorithm 
needs a certain amount of text to work properly and does not work for single words.

How to Access

• The language is suggested in the context menu of a misspelled word.

• Choose Tools -> Customize -> Toolbars -> Modify -> change icon.

Rectangular Selection

The block selection mode enables you to select rectangular regions of text, such as columns. This 
is useful, for example, if just small portions of a multicolumn text need to be selected.

Example 

Highlighting just one column is not possible with the standard selection.

With block selection, you can select a vertical column.

How to Access

• On the status bar, click STD several times until it reads BLK.

• Highlight the desired selection.



• You can also toggle the selection modes through the menu from Edit -> Selection Mode.

• Windows users can also enable block selection mode by pressing the Alt key while selecting 
with the mouse.

Mail Merge / Form Letter

Form Letter, also known as Mail Merge, is a popular feature for creating numerous personalized 
letters. A typical example is a promotion or invitation letter in which the address and the name 
differ but the rest of document is identical. Oracle Open Office provides a Mail Merge Wizard 
that guides you through the document creation process. You can add address fields, specify the 
datasource, and finally print the document. All the information is handy, and the mail merge 
creation goes smoothly.

 

How to Access

Choose Tools -> Mail Merge Wizard.

Direct Cross-References to Headings and Numbered Paragraphs in Text Documents

You can insert a cross-reference to a heading or a numbered paragraph directly into the current 
text document by selecting the heading or the numbered paragraph from a list.



How to Access

Choose Insert -> Cross-references.

Indexes and Tables

Oracle Open Office provides, besides a table of contents, six other index lists, including a 
bibliographic references index. 

How to Access

Choose Insert -> Indexes and Tables -> Indexes and Tables.



Outline Levels Management

Oracle Open Office has complex outline levels management that enables users to handle the 
complex outline numbering of scientific and legal papers. 

How to Access

Choose Tools -> Outline Numbering.

Oracle Open Office Calc

The Oracle Open Office Calc spreadsheet application enables you to calculate, analyze, share, 
and visually communicate your data quickly and easily.

Solver

Oracle Open Office’s Solver component enables you to solve optimization problems in which 
the optimum value of a particular spreadsheet cell has to be calculated according to constraints 
provided in other cells. The Solver component should be particularly interesting to Mac users, 
considering that Microsoft Office 2008 for Mac OS X does not include a solver feature. 

How to Access

Choose Tools -> Solver.

1,024 Columns per Calc Sheet 



With support for 1,024 columns and 65,536 rows, Oracle Open Office can handle large amounts 
of data and import large Microsoft Excel spreadsheets. 

Convert Text to Columns in Calc

With this feature, CSV (comma-separated value) data inside cells can be directly transformed into 
columns. This feature uses the existing text import dialog box and transforms CSV data inside 
cells into multiple columns. Example: A1 holds 1, 2, 3, 4. After use of this feature, 1, 2, 3, and 4 
are split into cells. Another example of using this feature is splitting cities and states such as “Los 
Angeles, California” or splitting last and first names (“Smith, John”).

How to Access

Choose Data -> Text to Columns.

Moving Columns and Rows in Spreadsheets via Drag-and-Drop in Calc

By default, the target cells are overwritten when you move or copy a marked cell range via drag-
and-drop to a new row or column. You can activate an insert drag-and-drop mode by pressing 
the Alt key in addition to the Shift and Ctrl keys before dropping. In such a case, the source data 
is inserted at the new position and the target cells are shifted to the right or down.

How to Access

• Highlight some cells.

• Drag the selected area.



• After you start dragging, press and hold the Alt key. Note that the dragged box has a thick 
black border on only one side. A thick border on the left indicates vertical insertion mode, and 
a thick border on the right indicates horizontal insertion mode.

• Drop by releasing the left mouse button.

Automatic Summation in Calc

You can select the cell range, and all values in the marked area are summed up column- and/or 
row-wise. The result is inserted automatically as a sum formula.

How to Access

Select the cell range, and click Sum.

Chart Component 

The Chart of Oracle Open Office provides 80 different chart types, including 3-D charts and a 
large set of features for creating compelling charts. Chart makes it easy to visualize your data.

Chart Wizard 

The wizard offers the selection of the chart types it deems most appropriate, and you can then 
change the chart type as necessary. The type can be selected on a single page, so there is no need 
to switch between pages or scroll around. A live preview displays the implications of the option 
changes instantly. 

How to Access

Choose Insert -> Chart, or click the Chart button in the toolbar.



Flexible Source Ranges

You can choose separate data ranges for each series and even select different x-values for 
different series. On the Data Series tab, you can change the source range addresses of all data 
series separately, including their labels and all data sequences. You can also change the range for 
the categories or data labels (for charts that do not support categories). 

How to Access

• The Chart Wizard contains the Data Ranges and Data Series tabs in its dialog box.

• There is also a separate dialog box under Format -> Data Ranges.

Support for 3-D Charts 

With the Right-angled axes option, you can easily ensure that the axes in a 3-D chart are 
exactly vertical or horizontal. This simplified display looks comfortable and allows for more-
accurate reading. 



How to Access

• Double-click the chart to enter chart edit mode.

• Choose Format -> 3D View, or select 3D View from the context menu. This modal dialog 
box works with a live preview.

Illumination Default Setting

The defaults for illumination were changed to fit the 3-D look with right-angled axes.

How to Access

• Double-click the chart to enter chart edit mode.

• Choose Format -> 3D View, or select 3D View from the context menu. This modal dialog 
box works with a live preview..

Logarithmic Scales

With logarithmic scales, you can choose minimum and maximum values. Thus, audio engineers 
can display their log charts from the typical 20 Hz to 20,000 Hz. The major intervals for 
logarithmic scales can also be changed.

How to Access

The scaling of the chart axis takes place on the Scale tab of the Axis dialog box: Format -> Axis 
-> x-Axis/y-Axis -> Scale tab.

Data Editor for Charts

For charts that display their own data, there is a dialog box for editing it. The Chart Data dialog 
box is where you can modify, add, and delete data that is used in data series and for categories. It 



is also possible to add and remove entire data series. All the parts of a data series can be changed 
in this dialog box. Charts with their own data are typically those in a presentation.

How to Access

• In a presentation document, choose Insert -> Chart, or click the Chart button in the toolbar.

• Choose View > Chart Data Table, or select Chart Data Table via the context menu.

Editing Regression Lines (Trend Lines) with Ease

For some chart types, it is possible to add trend lines to data series. A trend line shows an 
approximation of the values in a mathematical curve. In addition to the actual curve, a graph can 
also contain graphical objects for the equation of a trend line and the accuracy of the calculation, 
denoted by R².

How to Access

Choose Insert -> Trend Lines.

Regression Curves for 2-D Charts



Regression curves are available for 2-D line, bar, column, and area charts.

How to Access

• Select a data series in a 2-D line, bar, column, or area chart.

• Insert a trend line via the main or context menu.

Display Bars on Different Axes Next to Each Other

In bar charts with two y-axes, it is possible to display all the bars next to each other so that they 
do not overlap.

How to Access

• Create a bar chart with two y-axes.

• Choose Format -> Object Properties -> Options, and enable Show bars side by side.

Number Format for Data Labels

For data labels in charts, it is possible to choose a number format for the display of values and 
percentage values, and they can be displayed on separate lines.



How to Access

• Choose Insert -> Data Label.

• Alternatively, select a data series, choose Format -> Object Properties -> Data Labels -> 
Show value as number, and select a number format.

Display Both Value and Percentage as a Data Point Label

For data labels in charts, it is possible to display the value and the percentage value at the same 
time (see preceding screen shot).

How to Access

• Choose Insert > Data Label.

Alternatively, select a data series and choose Format -> Object Properties -> Data Labels 
-> Show value as percentage.Title for Secondary x- and y-Axes

The title dialog box now allows a secondary title for the x- and y-axes.



How to Access

Choose Insert -> Title.

Clockwise Direction and Starting Angle for Pie Charts

Two options are available for pie charts: Starting angle and Clockwise direction.

How to Access

Select a data series, and choose Format -> Object Properties -> Options.

Handling Missing Data

Chart handles missing data points—leave a gap, assume zero, or continue a line through the 
missing value. 

How to Access

Choose Insert -> Data.



Data Sorting

Calc provides powerful, easy-to-use data sorting capabilities. For example, it can sort by the 
column in which the cursor is located, look for column headers, and preserve the original order 
of entries with equal sort keys. In addition, the Sort Range dialog box asks if the sort should be 
extended to adjacent cells.

How to Access

Click the Data Sort or Sort button on the toolbar.

Manual Sorting in DataPilot

It is possible to rearrange items in a DataPilot field via drag-and-drop or copy-and-paste. The 
default sorting for new tables is Ascending; it is changed to Manual when items are moved.

How to Access

• Choose Data -> DataPilot -> Start.

• Create a DataPilot, and select Options.

• In the Data Field dialog box, select Options again to find the sort order.

Drill-Down in Data Field in DataPilot

Double-clicking in a DataPilot cell provides the calculation data of that cell. Double-clicking a 
cell within the data field inserts a new sheet containing a subset of rows from the original 
datasource that constitutes the result data displayed in that cell. For instance, when the SUM 
data field function is selected, the number shown in the data field cell must be identical to the 
sum of all the data field values in the corresponding rows displayed in the inserted sheet.

How to Access

• Double-click in the DataPilot cell.

• Alternatively, select Data -> Group and Outline -> Show Details.

Clipboard Format for CSV

When you are pasting unformatted text with a field delimiter, the CSV Text Import dialog box is 
opened to allow detailed processing of the content. The text must consist of more than one line, 
and the field delimiter can be a comma, semicolon, tab, or blank.



How to Access

Paste text with more than one line and field delimiters into Calc.

Adjustable Margins and Column Widths in Page Preview

Margins and column widths can be adjusted in the page preview. The page preview in Calc has a 
Margins toolbar button.

How to Access

• Choose File -> Page Preview.

• Select Margins.

Oracle Open Office Impress and Oracle Open Office Draw

The Oracle Open Office Impress application is a full-featured presentation tool, complete with 
animations, presenter views (for use during slide shows), slide transitions, and templates.

Oracle Presentation Minimizer

The Oracle Presentation Minimizer extension reduces the file size of the current presentation. 
Images are compressed, and data that is not needed is removed. It can also optimize the image 



quality size. Oracle Presentation Minimizer is perfect for presentations designed for screen or 
projector, because they do not require the same high quality as presentations designed for print.

How to Access

• Install the Oracle Presentation Minimizer extension from 
www.sun.com/software/staroffice/extensions.jsp#minimizer.

• Choose your platform, and begin the download of the extension: with an installed Oracle 
Presentation Minimizer extension, choose Tools -> Minimize Presentation.

Native Tables

In Impress and Draw, there is a better way to create tables than embedding Calc objects or using 
multiple shapes. It is possible to create native tables as you can in Writer. Table designs can be 
changed from the Table Design pane on the task panel in Impress or from the Table Design 
dialog box in Draw.



How to Access

Choose Insert -> Table, or click the table icon.

Oracle Presenter Console

The Oracle Presenter Console extension provides more control over your slide show 
presentation, such as the ability to see the upcoming slide, the slide notes, and a presentation 
timer while the audience sees only the current slide.

To avoid the confusion of displaying numerous presentation elements, Oracle Presenter Console 
displays only the elements you need on three different, easily changeable views.

• The first view displays the current slide, including the effects and the upcoming slide.



• The second view shows the speaker’s notes in large, clear, scalable type, plus the current and 
upcoming slide.

• The third view provides a slide sorter with the slide thumbnails.

Create Huge Documents with Draw

Draw enables you to create very large documents, as large as 300 cm by 300 cm.



How to Access

Choose Format -> Page.

Font Size Buttons

This useful tool in Impress and Draw for quickly changing the font size is located on the Text 
Formatting toolbar.

How to Access 

Click the Text Formatting toolbar.

Comments Enabled for Impress and Draw Files

Comments or notes can be inserted into Impress slides and Draw pages. This is an easy way to 
share comments and review presentations and drawings.

How to Access 

Insert comments.

HTML Export 

The HTML Export wizard for Draw and Impress generates a Web page from your presentation.



How to Access

• Choose File -> 

• Export.

• Select an HTML document.

Custom Animation Paths

The user interface for custom animation supports adding user-drawn motion path effects and 
editing the path of existing motion path effects.



How to Access

• Choose Custom Animation from the Slide Show menu.

• Click Add, and select Motion Paths in the Custom Animation dialog box.

Play Sound Throughout a Slide Show

It is possible to play sound without interruption while presenting multiple slides.

How to Access

Choose Slide Transition in the task pane, and choose Sound.

Easy-to-Use Crop Function 

With Oracle Open Office, cropping images works exactly as in most other desktop applications: 
it involves dragging handles at the edges and corners of an image.



How to Access

Select an image, and click the crop picture icon on the Picture toolbar.

Oracle Open Office Base

Oracle Open Office Base is a powerful database application that provides a query, form, and 
report editor. It supports numerous different database servers, such as the MySQL server, Oracle 
Application Server, and Microsoft SQL Server, and includes an integrated database engine. The 
integrated database engine makes it very easy to create new databases and can also integrate data, 
forms, reports, and queries into one file. 

Oracle Open Office Report Builder Extension

You can use the Oracle Open Office Report Builder extension to create stylish, sharp database 
reports. The flexible report editor can define group and page headers as well as group and page 
footers, and even calculation fields are available to help you create complex database reports.



How to Access

• Download and install the Oracle Open Office Report Builder extension, and click the 
following link to start the download: http://extensions.services.openoffice.org/
download/809

• Create a database.

• Choose Insert -> Report.

Support for Microsoft Access and Microsoft Access 2007

The Microsoft Access 97-2003 mdb and Microsoft Access 2007 accdb files are supported by 
Base. When creating a new database, you can select either MS Access or MS Access 2007 as the 
type to connect to. Note that this is available on Windows only.

How to Access

Create a new database via File -> New -> Database -> Connecting to an existing database 
-> Microsoft Access 2007.

Relation Design for MySQL

The relation design is available for MySQL databases.

How to Access

Create or edit a query, and choose Insert -> New Relation.



Allow Query Designer in SQL View

You can open the query designer from within the property browser for a database form. The 
query designer can be used to graphically design the SQL command underlying the form.

How to Access

Create or edit a query, and choose View -> Switch Design View On/Off.

Improved SQL Editing

The database application now supports an additional Edit in SQL View command, which can 
be applied to one or more queries.

How to Access

Select a saved query, and choose Edit -> Edit in SQL View.

“Queries in Queries” Feature

With the implementation of the “queries in queries” feature, it is now possible to add both tables 
and queries to other queries.

How to Access

Create or edit a query, and choose Insert -> Add Table or Query.

Macro Events at Form Controls

Much as with the form controls in text documents, providing the controls on database forms is a 
set of scripting events for calling scripting languages such as Oracle Open Office Basic.

Menu in Table Data View

The table data view of a table has an Insert -> Record menu entry. This command inserts a new 
row at the end of the data set.



Extensibility and Developer Features

Developers will particularly like Oracle Open Office. The many developer features make writing 
powerful extensions for Oracle Open Office simple, which has already led to the availability of 
more than 500 extensions in the public extension repository. Extensions can include their own 
help content, licenses, and configuration dialog boxes, and with the OpenOffice.org API Plug-In 
for NetBeans, developers can focus on implementing the application logic instead of having to 
learn extension development from scratch. Enterprise developers will also like that Oracle Open 
Office can run several Visual Basic for Applications (VBA) macros unmodified, leading to lower 
migration costs and increasing interoperability.

Extension Framework

Oracle Open Office enables you to develop powerful extensions that run on top of Oracle Open 
Office and OpenOffice.org. These extensions can include application help information, 
descriptive names, licensing information, and so on. Thus, Oracle Open Office provides a very 
powerful extension framework to developers who want to add functionality to Oracle Open 
Office and OpenOffice.org and create their own value-added offerings.

Extension Repository (on OpenOffice.org)

If you want to do more with your Oracle Open Office suite, check out the OpenOffice.org 
Extension Repository. It contains over  500 extensions, and more are added to the repository 
every month. It is likely that in the extension repository, you will find many of the features you 
are looking for.

Installing Oracle Open Office Extensions

Oracle Open Office extensions are very easy to install. You can install them directly from the 
OpenOffice.org Extension Repository, or if you have them available as local files (in OXT 
format), you can install them with a simple double-click. 

How to Access

• Open the file manager of your operating system.

• Double-click an extension file (OXT).



Software Update Notification

The software automatic update notification feature helps users keep their Oracle Open Office 
suite up-to-date, by notifying users when updates become available. This update mechanism also 
checks for updates to extensions.

Extension Updates

The Extension Manager dialog box shows all available updates that can be obtained 
automatically. You select the extensions to be updated, and the extension manager automatically 
downloads and installs the updates. 

How to Access

• Choose Tools -> Extensions -> Updates.

• Alternatively, go to the Oracle Open Office notification area.

VBA Support

Oracle Open Office can run many VBA macros unmodified, with its built-in partial VBA 
support. Because of the large number of Excel VBA symbols that must be emulated, many Excel 
macros will not run initially. This feature is available for Calc only.



Smart Tags

Oracle Open Office smart tags work similarly to Microsoft Office smart tags and add contextual 
information to Oracle Open Office documents. If any of the installed components recognize a 
piece of text, the text will be highlighted to indicate that a special action is associated with it.

For example, an e-mail address recognizer highlights all e-mail addresses in your document. One 
possible action associated with an “e-mail” smart tag type might be to start your e-mail client and 
insert the e-mail address into the To: field of a new message. Microsoft Office smart tags are not 
compatible with Oracle Open Office smart tags.

Participation and Collaboration

Oracle recommends Mozilla Thunderbird and Lightning, the leading open source 
communication client from the Mozilla community, for e-mail and calendar functionality. Oracle 
Open Office developers contributed heavily to the Mozilla Lightning project to turn it into an 
enterprise-class calendar client. 

Content management solutions help users who work in teams, by ensuring that all team members 
work with the latest document revision. Oracle Connector for Microsoft SharePoint Server and 
Oracle Connector for Alfresco CMS provide integration for Oracle Open Office with these 
document management solutions.

To simplify collaboration and integration with popular Web services, Oracle Open Office offers 
two powerful extensions, Oracle Wiki Publisher and Oracle Weblog Publisher. With these 
extensions, creating wiki pages and blog entries becomes a simple task. 

Oracle Open Office also simplifies the joint creation and editing of spreadsheet files via a 
workbook sharing feature. 

Oracle Connector for Microsoft SharePoint Server

Oracle Connector for Microsoft SharePoint Server makes Oracle Open Office the perfect 
SharePoint client and adds support for ODF with Microsoft Office SharePoint Server. 

The extension enables users to search, browse, edit, or check documents stored in Microsoft 
Windows SharePoint Services 3.0 in or out. It also extends the Microsoft Office SharePoint 2007 
Server front end to load Oracle Open Office files and enables Microsoft Office SharePoint 
Server to search within ODF documents.



How to Access

Install Oracle Connector for Microsoft SharePoint Server, which is available in Oracle Open 
Office Enterprise Edition.

Oracle Connector for Alfresco CMS

Alfresco is an open source alternative for enterprise content management (ECM). The Alfresco 
document repository delivers out-of-the-box collaborative content management. It simplifies 
capturing, sharing, and retrieving information across virtual teams. Oracle Connector for 
Alfresco CMS integrates Oracle Open Office within the Alfresco CMS solution. The user has full 
access to all documents stored on the Alfresco server. An easy-to-use and clear front end makes 
it easy to create, load, edit, and save documents, including checking in and checking out. This 
ability makes it easier to move to the fully supported Alfresco Workflow for auditing documents. 
Also provided are support of Alfresco spaces and the ability to search within the documents 
hosted on the Alfresco server.

How to Access

Download and install Oracle Connector for Alfresco CMS at the link below.

http://extensions.services.openoffice.org/en/node/2459

Spreadsheet Collaboration Through Workbook Sharing

This feature enables multiple users to collaborate on spreadsheets. By sharing a spreadsheet, 
several users can add their data to it. The spreadsheet owner can easily integrate the new data 
with a few clicks. The collaboration feature helps avoid editing conflicts.



How to Access

Choose Tools -> Share Documents.

Collaboration with Microsoft Office Users

There are two main strategies for collaborating with Microsoft Office users: using ODF or the 
Office document format. Choosing ODF is always the best strategy, because of the multiple 
advantages of the format. In addition, all Microsoft Office users can easily work with ODF. 
Oracle offers Oracle ODF Plugin for Microsoft Office, which enables Microsoft Office users to 
read and write ODF documents. Oracle ODF Plugin for Microsoft Office  can be downloaded 
and installed with a few clicks. Microsoft Office also offers ODF support with the Service 
Pack 2 for Microsoft Office 2007 and Microsoft Office 2010, but their implementation is not 
as robust. For better results, Oracle therefore strongly recommends Oracle ODF Plugin for 
Microsoft Office. 

The second strategy is to use the Microsoft Office format for documents being sent to Microsoft 
Office users while retaining ODF for all other documents. With the Send E-mail As function in 
Oracle Open Office, users can easily define the format of the document. This function is not 
only very easy to use but also has the advantage of not creating a local file in Microsoft Office 
format but only generating the file for the e-mail. If other collaboration systems are in use and 
don’t require e-mail, the Save As function can be also be used for creating documents in 
Microsoft Office format. Whenever the user receives documents in Microsoft Office format, the 
best way to handle them and avoid formatting issues is to save them to ODF.

How to Access

Choose File -> Send -> E-mail as Microsoft Word.

Spreadsheet and presentation documents files will be sent as Microsoft Excel or Microsoft 
PowerPoint files.

Oracle Wiki Publisher

Wikis are often used to create collaborative Web sites. The collaborative encyclopedia Wikipedia 
is one of the best-known wikis. In businesses, wikis are used to provide effective intranet 
environments for documentation purposes and knowledge management. However, MediaWiki 
users often need to learn a simplified markup language to create MediaWiki articles. Oracle Wiki 
Publisher makes creating new wiki pages on MediaWiki servers easy. It enables you to create and 
edit MediaWiki articles within Oracle Open Office Writer without needing to learn the syntax of 
the MediaWiki markup language.

How to Access



• Download and install Oracle Wiki Publisher, from 
http://www.sun.com/software/staroffice/extensions.jsp#wiki

• Choose Send -> MediaWiki Server.

Oracle Weblog Publisher 

Oracle Weblog Publisher enables you to quickly create, edit, and publish Weblog entries on 
Generic ATOM, Generic Meta, Weblog Roller, and WordPress servers. It is easy to use, so any 
user can start blogging right away. Use the advanced word processing features of Writer to create 
blogs with tables, bullets, hyperlinks, graphics, and spell checking via the Oracle Open Office’s 
spell-checking technology.

How to Access

• Download and install the Oracle Weblog Publisher extension, from 
http://www.sun.com/software/staroffice/extensions.jsp#weblog

• Use the Weblog menu to set up and publish Weblog articles.

Oracle Open Office Personal Information Manager: Mail/Calendar Client

Oracle recommends that Oracle Open Office customers use the Mozilla Thunderbird 
communication client and the Lightning calendar extension. Together, they serve as a personal 
information manager (PIM) and form a strong Microsoft Outlook alternative. 

The Mozilla Thunderbird e-mail client is one of the most popular cross-platform e-mail clients 
on the market. It is available on Windows, Mac, Linux, and Oracle Solaris. An account wizard 
helps you set up Thunderbird for your IMAP, POP3, or Gmail server account. Even News and 
RSS-Feed servers are supported.

A powerful spam and phishing filter protects you from e-mail scams and cuts out junk 
e-mails automatically. Thunderbird is a full-featured and powerful e-mail client. A list of more 
features and reviews of Thunderbird are available on the Thunderbird home page, at 
www.mozilla.com/thunderbird.

The calendaring add-on Lightning integrates perfectly into the Thunderbird e-mail client and 
manages your appointments and to-do items on either a local or a server-based calendar. The 
first release supports Oracle Communications Calendar Server and Google Calendar. Much as 
with other e-mail/calendar clients, the standard e-mail view is separated into three areas:

• On the task pane on the left, the e-mail and newsgroups folders

• In the center, the e-mail subjects and bodies



• On the right, a summary view of the appointments for today and tomorrow and the to-do 
items

Two additional views are available for a better overview of the appointments and to-do items. 
Scheduling meetings is easy because the PIM solution quickly provides an overview of the 
schedules of various team members. Once a meeting time and date have been selected, the 
invitation dialog box comes up and the attendees are automatically invited and receive all the 
relevant meeting information. Separate invitation e-mails for attendees are not required. 

The Calendar view provides a useful feature for displaying calendars from colleagues, and the 
search pane makes it easy to find appointments and to-do items. You can import and export 
iCalendar and Microsoft Outlook files for synchronizing calendars with people who do not use 
Oracle Communications Calendar Server or Google Calendar.

How to Access

Start the Mozilla Thunderbird e-mail client with an installed Lightning add-on.

Start Center

The Start Center offers all key initial tasks, such as creating various document types or opening 
existing documents, in one dialog box. When you open the Oracle Open Office application, the 



Start Center welcomes you and enables you to choose which module you would like to use or if 
you would prefer to open a document. 

Preview Documents in Web Browser

The Preview Document in Web Browser function provides an easy way to display the current 
document as an HTML export in the system Web browser.

How to Access

Choose File -> Preview in Web Browser.

Internationalization and Localization 

Oracle Open Office supports 17 languages: English, French, German, Spanish, Italian, Dutch, 
Brazilian Portuguese, Iberian Portuguese, Hungarian, Polish, Swedish, Russian, Arabic, Chinese 
(Simplified and Traditional), Japanese, and Korean.

Oracle Open Office has effective internationalization technologies, such as complex text layout, 
right-to-left capabilities, and bidirectional scripts to enable many more localizations. 

Conclusion

Powerful and integrated word processing, spreadsheet, presentation, drawing, and database 
capabilities as well as add-on extensions provide Oracle Open Office with the broad functionality 
you expect in an office productivity suite. With Oracle Open Office, users can read, edit, and 
save Microsoft Office files; import, edit and export PDF files; and take advantage of easy-to-use 
multilanguage functionality—all within a familiar user interface and at a great price. Additionally, 



Oracle Open Office runs on Microsoft Windows, Mac OS X, Linux, and Oracle Solaris (SPARC 
and x86). 

Oracle Open Office software is a low-cost, full-featured office productivity suite. All users will 
benefit from its compatibility, stability, reliability, security, and usability.
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